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File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Save Saves an opened document using the same file 

name.
Save As Saves an opened document to a specified file 

name.
Exit Exits Scenario Editor.



Edit menu commands

The Edit menu offers the following commands:

Buildings Default Edit default properties for buildings 
Troops Default Edit default values for all troops .

These values will be used in the future as default.
Monsters Default Edit default values for all monsters .

These values will be used in the future as default.
Weapons Default Edit default values for all weapons used in game.
Upgrade properties Edit upgrade’s properties and costs.
Units production cost Edit the costs of buildings and troops.
Scenario Properties Select the buildings you are allowed to build in the game.
Scenario Goals Here you can build multiple goals for your map.

The BUILD_AT, TOUCH and TOUCH_ITEM goals use locations defined 
from
Tools / Building Location & Tools / Troop Location  menus

Alliances In this dialog box you can set players alliances, 
which will be used as default.

Campaign Texts Edit texts used in campaign data.
Map properties Edit map description string and the terrain type (Meadows / 

Wilderness).

Edit selected unit This menu item is enabled only when one troop, building or monster is 
selected.
It starts a dialog box used to edit the private properties of selected 
troop, building or monster.
Shortcut : Left mouse double-click on item.

Edit inventory Edit the inventory of selected unit if it has one.
You can put artefacts in chests, hidden bags or in monster’s pockets.
Shortcut key : I

Delete Selection Deletes all selected items in the map.
Shortcut key : DEL



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Image under cursor If checked, the image of current tool will be
displayed under the mouse cursor.

Mini Map Shows or hides the “MiniMap” window.
Simple minimap drawing If checked, full colors are used for minimap drawing 

instead of dithered image.
Player menu commands

You can use up to eight players in the map.

The Player menu offers the following commands:

Player No. X Selects the player no. X for editing operations.

Player Properties Opens the property sheets which modify all player’s 
starting conditions and Artificial Intelligence settings.



Units menu commands

From here you can choose monsters and player specific units

Monsters Selects the monster you want to put in map.

According to the selected player’s race following 
menus
will display human, elf or greenskin units

Air troops
Land troops
Water troops
Buildings

Traps Selects the traps tool for current player.



Tools menu commands

The Tools menu offers the following commands:

Select Set the current tool to SELECT TOOL.
Drag and select units on map in order to edit them

Eraser Set the current tool to ERASER TOOL.
Erase all from map at a given location

Move / Copy Move or Copy any selectable item on map
If ALT key is down Copy action is initiated.

Map Brush Popup to soil brushes. 

Start Location Set Start Location for current player.
Building Location Set Location needed for BUILD_AT goal.
Troop Location Set Location for TOUCH and TOUCH_ITEM goals.

Chest Use it to place treasures on map.
Hidden bag Use it to place hidden treasures on map.
Info Mark Display messages if clicked (in game).

You can edit the message by double-clicking the 
mark

Grates Dungeon specific wall
Palisade Dungeon specific wall
Door It can be used only between dungeon walls

Map Generator The automatic map generator helps you to build a 
new map.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Contents Offers you an index to topics on which you can get
help.

Help Topics Offers you an index to topics on which you can get
help.

Using Help Helps you accommodate with Windows Help 
System

About Displays the version number of this application.



New command (File menu)

Use this command to create a new document in “Scenario Editor”.    Select the type of new 
file you want to create in the File New dialog box.    << Remove previous sentence if your 
application supports only one document type. >>

You can open an existing document with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



File New dialog box

<< Delete this help topic if your application supports only one document type. >>

Specify the type of document you wish to create:
<< List your application's document types here >>



Open command (File menu)

Use this command to open an existing document in a new window.    You can open multiple 
documents at once.    Use the Window menu to switch among the multiple open documents.  
See Window 1, 2, ... command.

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
<< List your application's file types here. >>

Drives
Select the drive in which “Scenario Editor” stores the file that you want to open. 

Directories
Select the directory in which “Scenario Editor” stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Save command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, “Scenario Editor” displays the Save As dialog box so 
you can name your document.    If you want to change the name and directory of an existing 
document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S

Remark :
Two valid players are needed.



Save As command (File menu)

Use this command to save and name the active document.    “Scenario Editor” displays the 
Save As dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.

Remark :
Two valid players are needed.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a document with a different name.    A filename can contain 
up to eight characters and an extension of up to three characters.    “Scenario Editor” 
adds the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 

<< Add other File Save As dialog box options depending on which ones your application 
chooses via the OFN_ flags of the OPENFILENAME structure used by the CFileDialog. >>



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Exit command (File menu)

Use this command to end your “Scenario Editor” session.    You can also use the Close 
command on the application Control menu.    “Scenario Editor” prompts you to save 
documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in “Scenario Editor”, such as File Open.    A check mark appears 
next to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in “Scenario Editor”,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new document.

Open an existing document.    “Scenario Editor” displays the Open dialog box, in 
which you can locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, “Scenario Editor” displays the Save As dialog box.

Select brush size to one cell.

Select brush size to nine cells.

Choose the select tool.

Set the soil brush : GRASS.

Set the soil brush : WATER.

Set the soil brush : MUD.

Set the soil brush : ROCKS.

Set the soil brush : SOFT Mountains.

Set the soil brush : HARD Mountains.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the “Scenario Editor” window.    To display or hide
the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate :

Current tool description.
X coordinate in the map underneath the mouse cursor. 
Y coordinate in the map underneath the mouse cursor.



Edit Selected Unit (Edit Menu)

If only one editable unit is selected, its particular values may be changed.

The editable units are buildings, troops, monsters and info marks.

For an info mark you can edit the text that will be displayed in game when you click 
on it.

Any building or troop can have its own hit point, armor, sight, range, color and name. 
You can set their upgrades done and make them prisoners. Troops prisoner can have costs 
and you can’t control them until you pay. If the prisoner’s cost is zero you gain control as 
soon as you touch him with another troop.

Default button sets all values to game default values (initial values).
Reset button sets all controls to the values they had when you opened the dialog box.

Shortcut: Left mouse button double-click on unit



Count units on map

Click on the Info toolbar button to achieve this function.
The dialog box will present you what kind of units are placed on map, how 

many they are and whose player they belong to.



Use right mouse button

 The right mouse button is used to adjust graphics variety.
 Right clicking on a soil cell will cycle the image through its varieties.
 You also can rotate a troop by right clicking its base cell.
 Dungeon door’s color can be changed this way.



Traps (Units menu)

The traps are invisible to your enemies and do not affect your troops nor your allies.
If the color of the trap does not match a valid player its will not affect the monsters.



Monsters (Units menu)

There are 30 different monsters in three categories: Sea Monsters, Flying Monsters
and Land Monsters.

Each monster has a different weapon and strength.

Sea monsters are Black Sea Monster, Blue Sea Monster and Green Sea Monster.

Flying monsters are snakes and gryphons. There are Black Snakes, Red Snakes, 
Green Snakes, Yellow Snakes and Black Gryphons, Yellow Gryphons, Cyan Gryphons.

Land monsters are hydras, golems, devils, skeletons and dragons. They came in the 
next colors : Black Hydra, Blue Hydra, Green Hydra, Black Golem, Blue Golem, Cyan Golem, 
Black Devil, Red Devil, Orange Devil, Yellow Devil, Black Skeleton, Red Skeleton, Cyan 
Skeleton, Yellow Skeleton, Black Dragon, Red Dragon, Violet Dragon, Blue Dragon, Orange 
Dragon and Green Dragon.

The monsters don’t fight one another and are against all players. 



Player Properties (Players menu)

The players properties dialog lets you set the amount of starting resources, the race 
(human / elf / greenskin) and the controller (human / computer) of selected player.

The selected property page displays the color of corresponding player and the text    
“NOT PRESENT” if there are no units of that color on map.

If you set a player as computer controlled, you will be able to modify the Artificial 
Intelligence settings : Type - computer’s general behaviour, Strategy, Performance and 
Harassment option.



Automatic Map Generator (Tools menu)

The map generator gives you the possibility to control the generation process.

Basic Style group selects the brush used to fill the entire map (background).

The General group is selects the types of brushes that will be used in generation to 
give a realistic look to your map.

The Options group offers the following commands : 
 Use All - sets all check boxes on
 Fill only - sets all check boxes off
 Create Islands - if checked the map generator will reserve for each player a 

zone on the map. The resources will be generated near these zones.
 Init Random - if checked you can set the random seed and the map generator

will produce the same map every time with a given set of checkings

The Resources group lets you set the amount of Forest, Gold and CropLand in number
of cells. The amount you set will be divided to the number of players to get the quantity of 
resources for each player.

The Number of Players control determines how many zones will be managed in order 
to create an equitable map.



MiniMap command (View menu)

Use this command to display or hide the Mini Map window, which shows the entire 
map at tiny dimensions

You can drag on minimap window to scroll the map. 
If the mouse right button is down the minimap image is zoomed. 

A check mark appears next to the menu item when the Mini Map is displayed.

Shortcut :    M



Map Brush popup ( Tools menu )

Selects brush size and soil brushes as follows :

Filler size 1x1 Any brush will affect only one cell in the map.
Filler size 3x3 Any brush will affect nine cells in the map.
Use filler If checked all brushes will use special filler

Grass Sets the tool to grass brush.
Water Sets the tool to water brush
Mud Sets the tool to mud brush
Rocks (sand) Sets the tool to rocks brush
Dungeon Sets the tool to dungeon brush
Soft Mountains Sets the tool to soft mountains brush
Hard Mountains Sets the tool to hard mountains brush
Ornamental objects Sets the tool to ornamental objects

Forest Set soil brush - forest
Gold Set soil brush - gold.
Crop Land Set soil brush - crop land (peasants get food from 

here)



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using “Scenario Editor” and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
“Scenario Editor”.



Context Help command 

Use the Context Help command to obtain help on some portion of “Scenario Editor”.    When 
you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow 
and question mark.    Then click somewhere in the “Scenario Editor” window, such as another
Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the “Scenario Editor” window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    “Scenario Editor” 
determines which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    “Scenario Editor” 
determines which window is previous according to the order in which you opened the 
windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Next Pane

<< Write application-specific help here. >>



Prev Pane

<< Write application-specific help here. >>



Modifying the Document

<< Write application-specific help here that provides an overview of how the user should 
modify a document using your application.    

If your application supports multiple document types and you want to have a distinct help 
topic for each, then use the help context i.d. generated by running the MAKEHELP.BAT file 
produced by AppWizard.    Alternatively, run MAKEHM as follows:

makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the
help context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the
first document type supported by your application.    AppWizard produces an alias in the .HPJ 
file for your application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for 
that document type. >>





No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each 
AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help topic for the 
Invalid Filename message box. >>



Valid Player :
A player with at least one unit on map (troop or building) and “Start Location” set.

A player isn’t complete if it has any building or troop and is not valid.
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